.::LvL
Q3A Database
Screenshots in ioquake3
Started by Takkie
avatar
Takkie Rep. 1536
#1   16 Dec 2020
I was taking some Screenshots in ioq3. I'd like to take some high res .jpg so I can adjust them in photoshop (photoshop doesn't handle .tga).
The resolution I got was something like 640x400 in .jpg
There must be something better. Any ideas anyone ;)
Edited 2.84 hours after the original posting.
avatar
raspatan Rep. 3003
#2   16 Dec 2020
Print screen? I use Linux and Gimp+screenshot is pretty well integrated, producing high quality images. Gimp also runs in Windows and Mac OS.
Edited 1.67 minutes after the original posting.
avatar
Takkie Rep. 1536
#3   16 Dec 2020
I run windows, gimp is an option to work with the .tga format. I hope someone figured out a way to make HQ Screenshots for photoshop. For my photography it is my to go to program...
avatar
Tig Rep. 984
#4   16 Dec 2020
If you are using ioquake3, you can bind screenshotJPEG instead - if you really want JPG images. There are a heap of other options you may want to tweak like r_ext_max_anisotropy "16", r_picmip "0" and r_subdivisions "4".

To break out of the 640x480 size, you will need to use r_mode "-1" and r_customheight and r_customwidth (then vid_restart).

My screenshot.cfg (which uses TGA format) is:

cg_useScreenShotJPEG "0"
cg_drawHUD "0"
cg_scorePlums "0"
cg_lagometer "0"
cg_simpleItems "0"
cg_drawIcons "0"
cg_draw3dIcons "0"
cg_drawFPS "0"
cg_drawTimer "0"
cg_drawStatus "0"
cg_draw2D "0"
cg_fov "100"
cg_drawGun "0"
cg_drawCrosshair "1"
cg_drawScores "0"
cg_drawWeaponBar "0"
cg_drawStatusHead "0"
cg_drawWatermark "2"
cg_watermarkSize "24"
com_maxfps "60"
com_hunkmegs "128"
cl_renderer "opengl1"
r_ext_compress_textures "0"
r_ext_compressed_textures "0"
r_ext_multitexture "1"
r_ext_texture_filter_anisotropic "1"
r_ext_max_anisotropy "16"
r_detailtextures "1"
r_texturebits "32"
r_colorbits "32"
r_depthbits "24"
r_customPixelAspect "1"
r_vertexLight "0"
r_lodbias "-2"
r_fastsky "0"
r_drawSun "0"
r_dynamiclight "1"
r_textureMode "GL_LINEAR_MIPMAP_LINEAR"
r_gamma "1"
r_picmip "0"
r_subdivisions "4"
r_ext_multisample "4"
r_fullscreen "1"
r_customheight "1200"
r_customwidth "1600"
r_mode "-1"
vid_restart

avatar
Takkie Rep. 1536
#5   16 Dec 2020
That is great. Thanks for sharing Tig.
I'll test this with quake3e and HQ texture pack. Both look very promising ;)
avatar
raspatan Rep. 3003
#6   16 Dec 2020
I meant taking a screenshot with Print Screen key which then opens with Gimp automatically. But Tig's solution is clearly the best!
avatar
Takkie Rep. 1536
#7   16 Dec 2020
@raspatan hey, that may come of use...
Thanks
avatar
Takkie Rep. 1536
#8   17 Dec 2020
OK I just installed quake3e and I am very impressed. I ran into this forum thread
www.gog.com/forum/...es_links_inside
and the HQ packs mentioned are... uhh worth mentioning... really worth the download. I also read that you can take
.bmp Screenshots so that I well test for sure.
Edited 28 seconds after the original posting.
avatar
raspatan Rep. 3003
#9   17 Dec 2020
@Takkie You're welcome.
I use these instructions: swissmacuser.ch/ho...-5k-resolution/
And use the HQQ mod too (www.moddb.com/mods...nloads/hqq-v36/).
There are some guys creating HD textures through AI. See www.moddb.com/mods...-neural-upscale and www.moddb.com/mods...-3-4xai-upscale I think I will switch to those in the future, since they look the most promising ones imo.
Edited 23 seconds after the original posting.
avatar
themuffinator Rep. 875
#10   18 Dec 2020
Have yet to try the neural packs although AI is definitely the way forward. I worked on my own texture set using AI on and off for some time and some upscales can be surprisingly good. There's still a lot that can be improved but I'm overall quite happy with the results...
ibb.co/mRR0pkb
ibb.co/Fbc7Xvh
ibb.co/9Yf7JkH
ibb.co/WKbZHZT
ibb.co/Bgn26L7
ibb.co/HgnpJcB
The next step would be to get a Wacom pad and some art skills to touch up any shortcomings in texture quality.
avatar
themuffinator Rep. 875
#11   18 Dec 2020
The problem is that Q3 isn't designed for widescreen, so no matter the quality of textures it'll still look awful without a widescreen fix. For anyone interested, here's an engine mod I made years ago that started as a way of adding quality of life fixes to Q3 and its many mods:
www.dropbox.com/s/...nlqk/ioq3pp.zip
github.com/themuffinator/ioq3-pp

It's got that hor+ aspect fix, UI aspect fix (set r_arc_uiMode 1), bloom with colour correction from WolfCam, QL bsp support, entity override dumping and loading to mod map entities and probably a bunch of other things I've completely forgot about. Give it a try if you're curious but be warned I didn't create any documentation for it so it's a case of digging around and finding features/new cvars.

It makes me want to revisit that idea but based on quake3e.

avatar
Takkie Rep. 1536
#12   19 Dec 2020
@themuffinator
The weapons in the images look cool. I like the detailed plasma effect on the plasma gun and railgun.
There is also an neural/AI pack for the weapons: www.moddb.com/mods...a-arcade-assets
Haven't tested it yet. It may solve what you tried to accomplish....
Quake3e with wide-screen works for me.
But note I just came back and it all feels a bit new and this wide-screen is my new normal :D
Edited 25 seconds after the original posting.
avatar
Hu-Ka Rep. 0
#13   04 Feb 2021
After a really intensive searching procedure I found the ioq3pp version of themuffinator and it solved all the issues I found when running std. ioq3, many thanks for that great work! (do you have an donation link? ;)
I have just one point which I could not solve so far:
There are always three annoying warning message when playing on servers (std. Q3 and OSP):
WARNING: server is not allowed to set g_synchronousClients=0
WARNING: server is not allowed to set pmove_msec=8
WARNING: server is not allowed to set pmove_fixed=0
Do you have any hint how to fix that or to suppress these warning messages?

Many thanks for your help!
ps. I am using the ioq3pp version from dropbox www.dropbox.com/s/...nlqk/ioq3pp.zip

avatar
Tig Rep. 984
#14   05 Feb 2021
@Hu-Ka : Sounds like the server is running a config that has set those values and is trying to push them to you as well.

Two options, ignore or set them on your system too.

If you want to add them, open your q3aconfig.cfg in a text editor and add the following lines:

seta g_synchronousClients "0"
seta pmove_msec "8"
seta pmove_fixed "0"

avatar
Hu-Ka Rep. 0
#15   28 days ago
Unfortunately that was not solving the issue (adding the lines to the q3 config). When I'm running my std. q3 or the Quake3E version, the warning message does not appear, so it's defentely an issue of ioq3pp. Also running a server with my ioq3pp version reports the same warning messages when playing on this server with ioq3pp.
avatar
Tig Rep. 984
#16   27 days ago
How are you starting ioquake3? Do you have any custom start scripts or batch files? If so, could you please include them.
avatar
themuffinator Rep. 875
#17   25 days ago
@Hu-Ka: Turns out there's some strange handling of those cvars from ioq3 engine-side when compiled in standalone mode... which I used for ioq3pp. I should have something brand-new to share in the coming week or so that'll pretty much make ioq3pp redundant, so not worth fixing now.
Edited 1.93 minutes after the original posting.
avatar
Hu-Ka Rep. 0
#18   25 days ago
@themuffinator: That's good news, I'm really looking forward to that. Is it already possible to share the thread/source where I can find the brand new version? I took me a really long time to find your iq3pp version which solved all my issues with ioq3, you should promote it much more. :-)
Thank you for your work so far!
avatar
themuffinator Rep. 875
#19   25 days ago
I will make the repo public very soon, just getting documentation sorted and getting some bugs ironed out.
It'll be based on quake3e and serve as a reboot and combination of my previously discontinued (and unreleased) projects.
Only registered members can post a reply.
Already registered? Sign in.